Konfigurasi Extended ACL (Access Control List) di Cisco Packet Tracer - BLOG NGOPREX
MASIGNCLEAN101

Konfigurasi Extended ACL (Access Control List) di Cisco Packet Tracer

 http://blogngoprex.blogspot.co.id/2018/01/konfigurasi-extended-acl-access-control.html

Konfigurasi Extended ACL (Access Control List) di Cisco Packet Tracer - Artikel kali ini masih membahas mengenai Jaringan Cisco. Di artikel sebelumnya saya sudah membahas tentang ACL yaitu Standard ACL, Nah pada artikel sekarang juga masih membahas tentang ACL tetapi dengan mode Extended ACL.

Untuk penjelasan ACL sudah saya jelaskan di artikel sebelumnya yaitu pada:
Konfigurasi Standard ACL (Access Control List) di Cisco Packet Tracer

Oke langsung saja ketahap konfigurasinya, berikut dibawah ini adalah langkah-langkahnya.

Seperti biasa, pertama silahkan buka aplikasi packet tracer sobat, kemudian buat topologi seperti pada gambar dibawah ini.
Gambar.1 Topologi
Selanjutnya silahkan isi ip address pada Server0, PC0 dan PC1 seperti gambar dibawah ini.
Gambar.2 Pengisian ip address pada Server0

Gambar.3 Pengisian ip address pada PC0

Gambar.4 Pengisian ip address pada PC1
Jika sudah mengisi ip address diatas, sekarang sobat akan mengkonfigurasi ip address untuk Router0 dan Router1.

Untuk ip address Router0 pada interface FastEthernet0/0 yaitu : 172.16.16.1/24, kemudian untuk ip address Router1 pada interface FastEthernet0/0 yaitu : 172.16.16.2/24.

Berikut perintah untuk konfigurasi ip addressnya :

Pada Router0 :
Router0(config)#int fa0/0
Router0(config-if)#ip address 172.16.16.1 255.255.255.0
Router0(config-if)#no shutdown
Router0(config-if)#exit

Router0(config)#int fa1/0
Router0(config-if)#ip address 192.168.1.1 255.255.255.0
Router0(config-if)#no shutdown
Router0(config-if)#exit

Pada Router1 :
Router1(config)#int fa0/0
Router1(config-if)#ip address 172.16.16.2 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#exit

Router1(config)#int fa1/0
Router1(config-if)#ip address 192.168.2.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#exit

Sekarang Router0 dan Router1 sudah terkonfigurasi ip address. Langkah selanjutnya yaitu sobat akan mengatur HTTP, DNS dan juga FTP pada Server0.

Oke, berikut cara mengatur HTTP, DNS dan FTP pada Server0 :

Pertama akan mengkonfigurasi HTTP dulu.
  1. Klik pada Server0, kemudian pilih tab [Services] dan di tab tersebut terdapat HTTP, dan pilih pada HTTP.
  2. Pastikan service HTTP dan HTTPS sudah ON.
  3. Disana ada file bernama index.html, klik edit untuk mengubah tampilan indexnya.
  4. Sobat bisa mengubahnya dengan script html. Kalo sudah silahkan save. Sebagai contoh, saya sudah mengubahnya menjadi seperti gambar dibawah ini.
Gambar.5 Konfigurasi HTTP Pada Server0
Kedua, akan mengkonfigurasi DNS.
  1. Masih pada Server0 dan pada tab [Service], disana juga terdapat pilihan DNS, klik pada DNS.
  2. Pastikan service DNS sudah ON.
  3. Disana terdapat opsi berupa "Name" untuk memasukan nama domain, "Type" untuk memilih jenis konversi dan "Address" untuk memasukan IP Address server. Silahkan sobat bisa isi opsi tersebut. Sebagai contoh sobat bisa lihat gambar dibawah ini.
Gambar.6 Konfigurasi DNS Pada Server0
Ketiga, akan mengkonfigurasi FTP.
  1. Masih pada tab [Services], disana terdapat pilihan FTP, klik pada FTP dan atur disana.
  2. Disana juga terdapat opsi berupa "Username" untuk memasukan nama user, "Password" tentunya untuk kata sandi.
  3. Dibawahnya juga terdapat pilihan untuk menentukan hak akses berupa "Write" untuk supaya user bisa menambah dokumen, "Read" untuk supaya file dapat dibaca oleh user, "Delete" supaya user dapat menghapus dokumen, "Rename" supaya user dapat mengubah nama suatu dokumen, dan terakhir yaitu "List" supaya user dapat melihat daftar dokumen.
  4. Silahkan sobat tentukan opsi diatas tadi. Sebagai contoh lihat gambar dibawah ini.
Gambar.7 Konfigurasi FTP Pada Server0
Konfigurasi pada server sudah selesai. Selanjutnya sobat akan mengkonfigurasi routing dengan jenis Routing Dynamic EIGRP dan nomor AS = 100. Berikut langkah konfigurasinya:

Pada Router0 :
Router0(config)#router eigrp 100
Router0(config-router)#no auto-summary
Router0(config-router)#network 192.168.1.0 0.0.0.255
Router0(config-router)#network 172.16.16.0 0.0.0.255
Router0(config-router)#exit

Pada Router1 :
Router1(config)#router eigrp 100
Router1(config-router)#no auto-summary
Router1(config-router)#network 192.168.2.0 0.0.0.255
Router1(config-router)#network 172.16.16.0 0.0.0.255
Router1(config-router)#exit

Keterangan : Perintah "no auto-summary" adalah supaya ip address tidak mengarah kepada kelas A, karena disini menggunakan kelas C.

Jika sudah silahkan cek tabel routing si Router0 dan Router1 dengan perintah : "show ip route". Lihat gambar dibawah.
Gambar.8 Melihat tabel routing pada Router0

Gambar.9 Melihat tabel routing pada Router1
Sekarang coba cek PING terlebih dahulu dari PC0 atau PC1 ke Server0 dengan ip address 192.168.1.224. Pastikan koneksi berhasil (Repply..) seperti pada gambar dibawah ini.
Gambar.10 Pengecekan PING Pada PC0

Gambar.11 Pengecekan PING Pada PC1
Nah sekarang, waktunya sobat untuk mengkonfigurasi Extended ACL.

Untuk penempatan ACL yaitu pada Router1. Kemudian untuk ketentuan filtering sekarang yaitu :
  • PC0 tidak bisa mengakses HTTP/WEB pada Server0, tetapi masih bisa mengakses FTP dan ICMP (Ping).
  • PC1 tidak bisa mengakses FTP pada Server0, tetapi masih bisa mengakses HTTP/WEB dan ICMP(Ping).
Langsung saja, berikut langkah konfigurasi Standard ACL :

Pada Router1 :
Router1(config)#ip access-list extended FILTER
Router1(config-ext-nacl)#deny tcp host 192.168.2.2 host 192.168.1.224 eq www
Router1(config-ext-nacl)#deny tcp host 192.168.2.3 host 192.168.1.224 eq ftp
Router1(config-ext-nacl)#permit ip any any
Router1(config-ext-nacl)#exit

Router1(config)#int fa1/0
Router1(config-if)#ip access-group FILTER in
Router1(config-if)#exit

Untuk melihat access-list yang sudah terkonfigurasi, sobat bisa menggunakan perintah "show access-list". Dibawah ini contoh gambarnya.
Gambar.12 Melihat daftar access-list pada Router1
Untuk pengecekannya, pertama silahkan cek pada PC0 di web-browser dan ketikan nama domain : blogngoprex.com (ini adalah nama domain yang sudah sobat konfigurasi pada Server0). Pastikan akses ke HTTP/WEB gagal. Tetapi untuk PING dan FTP masih bisa diakses.

Berikut gambar hasil pengecekan pada PC0 :
Gambar.13 Pengecekan HTTP (gagal) Pada PC0

Gambar.14 Pengecekan FTP (sukses) Pada PC0

Gambar.15 Pengecekan PING (sukses) Pada PC0
Sekarang cek pada PC1. SIlahkan buka web-browser dan ketikan nama domain : blogngoprex.com dan pastikan sobat berhasil mengaksesnya. Kemudian cek ke FTP, pastikan tidak dapat mengaksesnya. Dan juga cek PING, pastikan juga masih bisa mengaksesnya.

Berikut gambar hasil pengecekan pada PC1 :
Gambar.16 Pengecekan HTTP (sukses) Pada PC1

Gambar.17 Pengecekan FTP (gagal) Pada PC1

Gambar.18 Pengecekan PING (sukses) Pada PC1


Selesai..

Gimana sob sudah paham kan? hhee
Kalo belum silahkan tanyakan saja dikolom komentar.
Jika dirasa artikel ini bermanfaat, silahkan share ke medsos sobat 😊
Share This :
Muh Riza Faizal
avatar
Anonymous
avatar

Jika ada yang tidak dipahami, silahkan tanyakan saja :)

31 August 2018 at 08:31
avatar

nentuin in dan out nya gmn bang? sy masih belomm paham

10 October 2018 at 16:43
avatar

Untuk menentukan mana itu IN, lihat ethernet pada Router yang tersambung pada topologi LAN/Switch/PC. Itu dimaksudkan supaya membatasi akses masuk dari Server ke LAN.
Dan untuk OUT sebaliknya.

13 October 2018 at 18:39
avatar

min kalo yang acl extended tapi pake jalur vlan trunk , deny nya ke server , itu gimana ya min?

30 December 2019 at 20:40
avatar

dan ip vlan nya pake DHCP yang dari router nya

30 December 2019 at 20:42
Silahkan beri komentar yang membangun buat penulis.
notifications_active Notification
Blog ini membahas seputar konfigurasi jaringan, server dan lainnya yang berhubungan dengan teknologi dan komputer.
Done